It is currently 13 Oct 2015, 17:41

PS3 Controller & ARDrone API

Parrot SDK, Linux SDK, Java, PC, Mac, scripts for Parrot drones... etc.
Posts: 1
Joined: 27 Dec 2011, 22:40

PS3 Controller & ARDrone API

Unread post by bzowk » 30 Dec 2011, 18:41

Good Morning All -

Yesterday, I set installed and set up the ARDrone SAPI/DK (1.8) on my Linux machine. I'm able to connect and see the stats from my Drone, but the PS3 controller doesn't seem to work.

Here's what I did: I installed a fresh copy of Ubuntu 11.10 on a spare laptop, updated it, then followed the instructions in the pinned post "Linux (Ubuntu) SDK Example Walkthrough." When I tried to make the first package in those instructions, though, I did find out that I had to manually install a few more components.

Once set up, I connect to the Drone's WiFi, then launch the app. I can immediatly see the yaw and pitch working and can also see the live video so it's communicating without a doubt. Even though my PS3 controller is connected, no buttons seem to respond.

Does the PS3 controller require being plugged in USB to work with this app or may it be set up via Bluetooth too? When it's plugged it USB, all 4 of the red lights on the controller blink the whole time. Shouldn't just the #1 one be lit when connected with a driver installed?

As far as the Bluetooth, I tried to connect it, but it did not see it. I was able to locate instructions and drivers to connect it. The furthest I got was the computer being able to see the "PS3 CONTROLLER" via Bluetooth, but I couldn't get a successful connection even though I tried various pair codes and lack of them too.

So (Long Story Short) - How do I get the controller to work with the ARDrone API and is there a working Bluetooth option?


Posts: 8
Joined: 04 Jan 2012, 01:44

Re: PS3 Controller & ARDrone API

Unread post by cowmoo32 » 04 Jan 2012, 02:53

I hit the same problem. I get feedback when I run jstest but when I launch the application I can neither map the PS buttons to the control menu nor get the drone to launch with the default settings

Posts: 1
Joined: 27 Sep 2011, 23:48

Re: PS3 Controller & ARDrone API

Unread post by djaniel » 10 Mar 2012, 19:24

Did you manage to solve this? I solved it this way:

Under {AR_SDK}/Examples/Linux/Navigation/Sources/common/

1.Edit file 'mobile_main.c' by uncommenting #include <UI/gamepad.h>

2.In function ardrone_tool_init_custom(...) uncomment ardrone_tool_input_add(&gamepad) AND comment line ardrone_tool_input_add(&control_device)

That's it, remake and test. It worked for me.

Posts: 8
Joined: 04 Jan 2012, 01:44

Re: PS3 Controller & ARDrone API

Unread post by cowmoo32 » 19 Mar 2012, 23:52

Still nothing. I can't figure out how to get the thing off the ground using the Nav demo. jstest shows the controller and the computer is receiving inputs. I can get it to work fine with the linux demo but when I try to map buttons in the Nav demo all I get is a -13 for one of the buttons and the rest are blank.

Return to Application Development

Who is online

Users browsing this forum: No registered users and 0 guests